enable
configure terminal
# 配置主机名
hostname WirelessController
# 配置管理接口
interface GigabitEthernet1
ip address 192.168.1.2 255.255.255.0
no shutdown
# 配置SSH访问
ip domain-name yourdomain.com
crypto key generate rsa general-keys modulus 2048
aaa new-model
aaa authentication login default local
aaa authorization exec default local
username admin privilege 15 secret YourStrongPassword
line vty 0 15
transport input ssh
login local
exit
# 配置NTP服务器
ntp server pool.ntp.org
# 配置时间区域
clock timezone PST -8
# 配置SNMP
snmp-server community YourSNMPCommunity RO
snmp-server host 192.168.1.10 version 2c YourSNMPCommunity
# 配置日志
logging host 192.168.1.20
logging trap informational
# 配置 WLAN
wlan Your_WLAN_Name 1 Your_WLAN_SSID
no shutdown
security wpa wpa2
security pre-shared-key Your_WLAN_Password
# 配置接口
interface wlan Your_WLAN_Name
guest-mode
!
# 配置端口
interface GigabitEthernet2
switchport mode trunk
switchport trunk allowed vlan all
# 保存配置
end
write memory